MikroTik Stuff

1/11/14

Cara Merubah Default Port SSH Pada OS Debian

Halllo kawan, sudah lama gak posting nie. Maaaf ya karena banyaknya kesibukan offline, aku pada artikel ini ingin menulis artikel cara merubah settingan ssh pada os debian, khususnya untuk merubah port nya, artikel ini juga dapat diaplikasikan pada mesin ubuntu dan centos.
 
Sekedar informasi perubahan port ssh guna untuk meningkatkan keamanan server, peretas pada umumnya masuk melalu jaringan ssh jika kita merubah port default ssh secara tidak langsung akan mempersulit peretas untuk mengakses server kita meskipun sudah mengetahui ip address server kita.

Tutorial Merubah Default Port 22 SSH


Pastikan mesin debian kalian, sudah terinstall ssh server jika belum silahkan simak pada artikel saya cara install openssh server pada os debian. Okey, ikuti langkah berikut ini :

1. Masuk ke terminal debian, dan ketik perintah

vi /etc/ssh/sshd_config

2. Kemudian tekan tombol "i" pada keyboard dan ganti bagian

Port 22

ganti dengan port yang anda inginkan misalnya

Port 1945

3. Simpan konfigurasi dengan menekan tombol "Esc" dan ":+x' pada keyboard
4. restart service ssh dengan mengetik

service ssh restart

Selesai sekarang coba akses ssh nya dengan putty atau bitvise. Semoga membantu ya

12/16/13

[VIDEO] Cara Install & Setting Mikrotik Router OS Pada Vmware

Kali ini saya akan memberikan video tutorial cara install & setting mikrotik router os pada vmware. Sekedar mengingatkan pada artikel kemarin saya sudah pernah menyampaikan cara install mikrotik router os pada virtualbox sekarang saya akan memberikan tutorial yang sama tetapi menggunakan aplikasi yang berbeda yaitu vmware. Enaknya memakai vmware itu fitur NAT dapat bekerja dengan sempurna, berbeda dengan virtualbox yang mana fitur NAT tidak dapat berjalan dengan semestinya. Sehingga proses belajar mikrotik menggunaan vmware jauh lebih leluasa, okey langsung aja simak video tutorial dibawah.

Video Tutorial Install & Setting Mikrotik Router OS Pada Vmware




Bagaimana video tutorial pertama saya? jelek yaa! hehehe, maaf guys thats my first video. Jangan lihat jeleknya guys tetapi niat untuk berbagi dalam bentuk video tutorial, semoga bermanfaat ya nantikan video tutorial lainnya.

12/8/13

Basic Belajar MikroTik - Pengenalan Commands Pada Mikrotik

Jika kita melakukan konfigurasi dengan winbox mungkin kita tidak perlu menghafal kode perintah commands untuk melakukan konfigurasi router mikrotik kita. Lalu bagaimana jika melakukan konfigurasi melalu terminal mikrotik? tentu kita perlu mengetahui dasar-dasar kode perintah/commands yang terdapat pada terminal mikrotik, saya pribadi lebih senang melakukan konfigurasi router mikrotik menggunakan terminal dari pada menggunakan winbox.

Dasar kode perintah atau commands pada Mikrotik



  • certificate 
  • import  
  • log  
  • ppp 
  • redo 
  • Special- login
  • driver 
  • interface 
  • password 
  • queue 
  • routing 
  • system
  • ip 
  • ping 
  • quit 
  • setup 
  • tool 
  • file
  • isdn-channels 
  • user export 
  • port 
  • radius 
  • snmp
  • undo

Diatas adalah beberpa kode perintah / commands pada terminal mikrotik, mungkin teman-teman ada yang mau menambahkan silahkan tambahkan pada form komentar ya. Sekarang kita lanjut pada contoh penerapan kode perintah / commands mikrotik.

Untuk melihat interface yang terpasang

# interface list


Untuk memberi name interface

# interface set (nomor interface) name=nama interface

Note ; nomor interface dapat dilihat saat mengecek interface yang terpasang


Untuk menambah ip address

# ip address add address=(masukan ip addressnya) interface=(nama interface)


Untuk menambah gateway

# ip route add gateway=(masukan ip gateway)


Untuk memberi dns

# ip dns set primary-dns=(masukan ip dns primary)



# ip dns set seconday-dns=(masukan ip dns secondayry)



Demikian artikel pengenalan basic belajar mikrotik untuk commands pada terminal mikrotik dan contoh penerapannya. Semoga dapat membantu

12/6/13

Basic Belajar MikroTik - Pengenalan Paket Fitur Dalam Router OS MikroTik

Basic Belajar MikroTik - Dalam berbagai artikel dan tutorial yang telah saya buat kemarin, saya belum pernah menjelaskan basic pembelajaran mikrotik yang membuat kontak email dan sms saya penuh dengan pertanyaan dasar. Seharusnya pertanyaan dasar seperti itu ditulis didalam form komentar yang tersedia :(, entah mungkin mereka malu aib nya ketahuan hehehe :P. Mulai hari ini kedepannya saya akan membahas basic belajar mikrotik terlebih dahulu sebelum saya membahas ketingkat yang lebih tinggi dan lebih ruwet (lebay detected) :D

Kali ini saya ingin memberikan sedikit coretan mengenai basic belajar mikrotik, dalam router os mikrotik terdapat berbagai paket yang memiliki fungsi dan tugas berbeda-beda.

Pengenalan Paket-paket yang terdapat dalam fitur MikroTik Router OS 



  • PPP : Untuk membuat Point to Point
  • dhcp : Packet yang dibutuhkan apabila ingin membuat dhcp-server atau untuk mendapatkan dynamic ip address.
  • Advanced tool : Tools tambahan seperti ip-scan, bandwidth test dan lainnya.
  • arlan : Packet untuk konfigurasi chipset wireless aironet arlan
  • gps : Packet untuk support GPS Device
  • hotspot : Packet untuk membuat hotspot gateway, seperti authentication , traffic quota dan SSL
  • hotspot –fix : Tambahan packet hotspot
  • isdn : Packet untuk isdn server dan isdn client membutuhkan packet PPP
  •  lcd : Packet untuk customize port lcd
  • ntp : Packet untuk ntp server dan ntp client
  • radiolan : Driver for legacy RadioLAN cards.
  • Routerboard : Routerboard spesifikasi BIOS
  • Routing : Packet untuk routing OSPF, BGP dan static
  • Routing-test : Packet tambahan ( optional )
  • security : Packet untuk mendukung ssh dan ip sec.
  • synchronous : Untuk synchronous dengan device lain
  • telephony : Packet for VOIP ( H.323 )
  • ups : packet for ups monitor seperti alarm
  • user-manager : Packet tool user manager untuk radius server
  • web-proxy : packet untuk setting proxy server
  • web-proxy test : optional
  • wireless : Packet untuk dukung cisco aironet cards
Demikian beberapa paket yang terdapat dalam fitur mikrotik, semoga dapat membantu dalam belajar mikrotik. Ini hanya pengetahuan dasar tingkat pertama, dalam artikel selanjutnya saya akan membahas materi basic mikrotik lainnya.

12/5/13

Cara Setting Online CCTV

Pada kesempatan kali ini saya akan memberikan tutorial cara setting online cctv agar cctv dapat diakses melalui web. Hal yang perlu kita otak-atik hanya DVR & modem aja gak perlu otak-atik yang lain lo ya gan, okey sebelumnya kita basa basi dulu dech. Apa sih manfaat cctv? menurut ane nie manfaat cctv itu ada 5, pertamax untuk pencegahan atau deterance pelaku kriminal kemungkinan akan mengurungkan niat jahatnya setelah melihat ada cctv yang terpasang, keduax pemantauan atau monitoring yang satu ini gak perlu ane jelasin ya. kemudian ketigax peningkatan kerja atau intensify karyawan akan merasa diawasi sehingga lebih produktif cocok dipasang di pabrik, toko, swalayan dll. Kempatax  penyelidikan atau investigation apabila terjadi kriminalitas bisa diselidiki pelakunya dari rekaman cctv, kelimax bukti kejadian atau evidance hasil rekaman cctv dapat dijadikan bukti untuk pihak kepolisian dan pengadilan.

Sekarang kita kembali ke topik judul cara setting online cctv,langkah pertama kita harus melakukan standarisasi IP dan konsep terlebih dahulu seperti biasa gan. Oke contoh kasus

Tutotrial Setting Online CCTV


- IP Adress Modem Speedy : 192.168.1.1
- IP Address DVR : 192.168.1.2
- Subnet : 255.255.255.0
-  Gateway DVR : 192.168.1.1 (Diarahkan ke modem speedy)
- Port : 5445
- DNS Host : dari no-ip.com
- Hostname ; diponk-host.no-ip.org
- username : diponk
- password : xxxCencoredxx

Dari standarisasi diatas saya menggunakan host dns gratisan dari situs no-ip.com, yang belum punya akun silahkan daftar terlebih dahulu dan buat dns host anda. Kita lanjutkan setting NAT pada modem adsl disini saya menggunakan modem tp-link  masuk ke Advance Setup ==> NAT



Isi sesuai data dibawah
- Rule                            1
- Aplication                   http
- Protocol                     All
- Star port Number        5445
- End port Number         5445
- Local IP Address         192.168.1.2

Klik Save/Apply untuk menyimpan. Kemudian lakukan konfigurasi pada DVR sesuai contoh standarisasi dibawah

- IP Address : 192.168.1.2
- Subnet : 255.255.255.0
- Gateway  : 192.168.1.1
- Port : 5445
- Hostname ; diponk-host.no-ip.org
- username : diponk
- password : xxxCenc*redxx

Maaf gak ada SS untuk setting di dvr nya, kamera lagi ngambeg nie. :p hehehe Jika sudah tancapkan kabel LAN dari modem ke DVR. Kemudian coba akses http://192.168.1.2:5445/  bisa kan? kalau gak bisa coba periksa konfigurasinya ip dan port nya.

Okey, demikian sedikit tutorial cara setting online cctv. Semoga membantu jika masih kesulitan silahkan laporan di pos komentar dibawah atau jika gak mau repot silahkan PM saya untuk jasa setting :)

11/29/13

Download MikroTik Script Maker


Dulu waktu saya dalam proses belajar mikrotik, bagian materi pembuatan script lah yang paling saya bingungkan bahkan sampai sekarang masih belum menguasai sepenuhnya. Ya maklum gak bisa bahasa programers biasanya saya pakai bahasa tubuh hehehe :D, saat ini sudah ada software buatan kocok jaya team untuk membuat script mikrotik secara mudah dan gamblang.

Software MikroTik Script Maker V3 tentu akan sangat membantu kita untuk melakukan scripting dalam konfigurasi jaringan mikrotik kita, software ini sudah dilengkapi untuk pembuatan script simple queue, queue tree + mangle, simple IIX + queue IX + mangle AIO, create dota, dan remote script. Sangat membantu kita pembuatan script mikrotik kan, saya rasa beberapa fitur yang diberikan pada software ini sudah lumayan cukup lah untuk kebutuhan konfigurasi jaringan mikrotik kita.

Bagi yang berminat atau pengen nambah koleksi, silahkan download gratis software mikrotik script maker ini di http://sdrv.ms/1iiFSon semoga bermanfaat ya.

Cara Memisahkan Gateway Lokal (IIX) dan Internasional

Pada kesempatan ini saya ingin membagikan hasil uji coba saya untuk memisahkan traffic gateway lokal IIX dan Internasional. Fungsi dari pemisahan gateway sendiri hanya sebagai manajemen bandwidth, saya sendiri belum pernah mencoba manajemen seperti ini kepada klien yang memakai jasa saya karena memang tidak ada yang minta manajemen seperti ini hehehe Open-mouthed smile  tapi tak apalah mari kita bahas disini sebagai bahan belajar bersama.

 

Contoh kasus memisahkan gateway traffic lokal dan internasional

 

Pertama yang diperlukan untuk melakukan manajemen pemisahan traffic gateway adalah tiga buah NIC yang berguna untuk 1 dari traffic lokal, 1 traffic internasional, dan 1 untuk traffic distribusi jaringan lokal. Asumsikan kita sudah memenuhi kebutuhan tersebut, kemudian kita perlu melakukan standart penamaan interface dan IP agar tidak pusing settingnya.

 

Nama-nama interface nya lokal, internasional, dan  distribusi. Sedangkan standarisasi IP nya adalah 192.168.3.0/24 untuk jaringan distribusi, 39.172.40.2/30 untuk jaringan traffic lokal, 172.80.124.1/30 untuk jaringan Internasional. Kemudian kita masuk ke tahap konfigurasinya, buka terminal mikrotik lalu ikuti langkah-langkah berikut :

 

/ Interface set 0 name=distribusi


/ interface set 1 name=internasional


/ Interface set 2 name=lokal


/ ip address add address=192.168.3.0/24 interface=distribusi comment="ip trafik distribusi"
disabled=no
/ ip address add address=172.80.124.1/30 interface=Internasional comment="ip trafik
internasional" disabled=no
/ ip address add address=39.172.40.2/30 interface=Lokal comment="ip trafik IIX" disabled=no


/ ip firewall mangle add chain=prerouting in-interface=distribusi dst-address-list=nice action=markrouting new-routing-mark=nice2 passthrough=yes comment="mark nice trafic" disabled=no


/ ip route add dst-address=0.0.0.0/0 gateway=172.80.124.1 scope=255 target-scope=10 comment="gateway traffic internasional" disabled=no
/ ip route add dst-address=0.0.0.0/0 gateway=39.172.40.2 scope=255 target-scope=10 comment="gateway traffic IIX" mark=nice2 disabled=no


/ queue simple add name="IIX-Client-01" max-limit=256000/256000 dst-address="192.168.3.12" interface=lokal
/ queue simple add name="INT-Client-01" max-limit=64000/64000 dst-address="192.168.3.12" interface=internasional


 


Catatan : Pemisahan traffic antara gateway lokal dan internasional hanya untuk client yang menggunakan ip address 192.168.3.12 yang sudah kita setting pada queue simple tadi.


 


Demikian tutorial memisahkan traffic gateway lokal (IIX) dan Internasional pada router mikrotik. Semoga dapat membantu

11/28/13

Connection Byte Untuk Mendetect dan Shapping Traffic Download

Tutorial ini berguna untuk membatasi aktifitas traffic download berdasarkan perhitungan byte, cara ini merupakan alterantif bagi yang kesulitan dalam penggunaan fitur delaypool. Dalam penggunaan connection byets pada fitur mangle dapat berguna untuk mendeteksi jumlah bytes yang telah diteransfer dalam satu koneksi, misalnya jika klien IP 192.168.3.20 mengakses 39.202.3.2 maka selama terjadinya koneksi yang terjadi connection bytes secara otomatis akan mencatat jumlah traffic bandwidth yang terjadi dalam koneksi tersebut hingga koneksi terputus. Mari kita langsung pada contoh kasus agar lebih mudah difahami.

Contoh Kasus Penerapan Connection Byte


Saya ingin membatasi klien 192.168.3.20 jika melakukan koneksi ke suatu situs dengan ip 39.202.3.2 misalnya.!!! Kemudian saya akan memberikan prioritas 1 jaringan dengan kecepatan 128kbps jika dia masih dalam koneksi dengan jumlah byte yang kecil antara 0-512 KB selama koneksi ke situs tersebut, dan jika dia melebihi dari kapasitas byte yang telah saya tentukan sebesar 512KB maka koneksi jaringan dia akan pindah ke jaringan prioritas 2 dengan kecepatan 32kbps.

Saya harap sejauh ini contoh kasus diatas dipahami :) sekarang kita lanjut ke tahap konfigurasinya. Buka terminal mikrotik lalu ketik perintah

/ chain=postrouting out-interface=ether1 dst-address=192.168.3.0/24 protocol=tcp src-port=80 action=markconnection new-connection-mark=http_conn passthrough=yes

/ chain=postrouting out-interface=ether1 dst-address=192.168.3.20 connection-mark=http_conn connectionbytes=0-131072 action=mark-packet new-packet-mark=client12_browsing passthrough=no

/ chain=postrouting out-interface=ether1 dst-address=192.168.3.20 connection-mark=http_conn connectionbytes=131073-4294967295 action=mark-packet new-packet-mark=client12_download passthrough=no

/ name="browsing" kind=pcq pcq-rate=128000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000

/ name="download" kind=pcq pcq-rate=32000 pcq-limit=50 pcq-classifier=dst-address pcq-total-limit=2000

/ name="choi" parent=ether1 packet-mark="" limit-at=1024000 queue=default priority=3 max-limit=1024000 burst-limit=0 burst-threshold=0 burst-time=0s 
/ name="client12_browsing" parent=choi packet-mark="client12_browsing" limit-at=0 queue=browsing priority=1 max-limit=0 burst-limit=0 burst-threshold=0
/ name="client12_download" parent=choi packet-mark="client12_download" limit-at=0 queue=download priority=2 max-limit=0 burst-limit=0 burst-threshold=0

Demikian tutorial pemanfaatan connection byte untuk detect dan shapping traffic pada router mikrotik. Semoga membantu, jika ada kesalahan mohon komentarnya kritik dan saran kalian akan sangat bermanfaat.

11/27/13

Cara Limit Traffic Download Untuk Situs Tertentu

Setiap situs mempunyai server dan kebijakan kecepatan tersendiri, ada yang membatasi kecepatan download free membernya ada pula yang mengijinkan full speed untuk semua member. Ada beberapa situs yang memberikan ijin kecepatan download traffic maksimal seperti rapidshare, indowebster, mediafire dll.

Pada tutorial ini saya akan membagi cara limit traffic download untuk situs tertentu hal ini mungkin berguna sebagai bahan edukasi saja, pasalnya metode yang paling efisien ada pada tutorial yang saya tulis kemarin Manajemen Bandwidth Mikrotik . Oke, disini saya menggunakan contoh untuk situs rapishare dan Router OS Mikrotik v5.26 silahkan simak langkah-langkah berikut.

Limit Traffic Download Untuk Situs Tertentu Dengan Mikrotik


Langkah pertama buka WinBox masuk ke System > Scheduler kemudian masukan kode script dibawah :


:foreach i in=[/ip dns cache find] do={

:if ([:find [/ip dns cache get $i name] "rapidshare"] > 0) do={

:log info ("rapidshare: " . [/ip dns cache get $i name] . " (ip address " . [/ip dns

cache get $i address] . ")")

/ip firewall address-list add address=[/ip dns cache get $i address] list=rapidshare

disabled=no

}

}


Note : Perhatikan yang bercetak tebal, silahkan diganti sesuai situs yang yang ingin di limit.


Pada pengaturan schedule interval saya set 1 menit, silahkan ganti sesuai selera. Setelah itu biasanya akan muncul address list baru kira-kira seperti ini



Kita lanjut dengan membuat rule mangle untuk mark connection  dan mark packet perhatikan baik-baik gambar dibawah ini untuk membuar mangle rule nya.

Mark Conn - Mangle Rule

Mark Packet - Mangle Rule

Kemudian kita buat Queue, saya pakai Simpel Queue lihat gambar dibawah ini



Selesai, silahkan diubah langkah-langkah diatas jika ingin menentukan target situs lainnya.

11/25/13

Setting Firewall Mikrotik Untuk Block Virus dan Serangan Hacker

Internet merupakan salah satu gerbang utama masuknya virus, hal itu tidak bisa kita pungkiri dalam mengakses internet tiba-tiba komputer kita terdapat banyak virus. Meskipun tidak kita sadari virus itu bisa masuk dalam komputer kita melalui web, video, atau software, maka dari itu kita perlu membuat filter. Adanya fitur firewall dalam router mikrotik menjadi salah satu penangkal kita untuk menghindari masuknya virus.

Saya mempunyai beberapa konfigurasi firewall chain mikrotik untuk menangkal masuknya virus dan serangan hacker dari dunia gaib :D yang akan saya share pada kalian. Okey, perhatikan baik-baik langkah-langkah dibawah

Cara Setting Firewall Mikrotik Untuk Block Virus dan Serangan Hacker


Langkah pertama buka terminal mikrotik kalian, kemudian masukan kode perintah dibawah

ip firewall filter



add chain=virus protocol=tcp dst-port=135-139 action=drop comment="Drop Blaster Worm"



add chain=virus protocol=udp dst-port=135-139 action=drop comment="Drop Messenger Worm"



add chain=virus protocol=tcp dst-port=445 action=drop comment="Drop Blaster Worm"



add chain=virus protocol=udp dst-port=445 action=drop comment="Drop Blaster Worm"



add chain=virus protocol=tcp dst-port=593 action=drop comment="________"



add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment="________"



add chain=virus protocol=tcp dst-port=1080 action=drop comment="Drop MyDoom"



add chain=virus protocol=tcp dst-port=1214 action=drop comment="________"



add chain=virus protocol=tcp dst-port=1363 action=drop comment="ndm requester"



add chain=virus protocol=tcp dst-port=1364 action=drop comment="ndm server"



add chain=virus protocol=tcp dst-port=1368 action=drop comment="screen cast"



add chain=virus protocol=tcp dst-port=1373 action=drop comment="hromgrafx"



add chain=virus protocol=tcp dst-port=1377 action=drop comment="cichlid"



add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment="Worm"



add chain=virus protocol=tcp dst-port=2745 action=drop comment="Bagle Virus"



add chain=virus protocol=tcp dst-port=2283 action=drop comment="Drop Dumaru.Y"



add chain=virus protocol=tcp dst-port=2535 action=drop comment="Drop Beagle"



add chain=virus protocol=tcp dst-port=2745 action=drop comment="Drop Beagle.C-K"



add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment="Drop MyDoom"



add chain=virus protocol=tcp dst-port=3410 action=drop comment="Drop Backdoor OptixPro"



add chain=virus protocol=tcp dst-port=4444 action=drop comment="Worm"



add chain=virus protocol=udp dst-port=4444 action=drop comment="Worm"



add chain=virus protocol=tcp dst-port=5554 action=drop comment="Drop Sasser"



add chain=virus protocol=tcp dst-port=8866 action=drop comment="Drop Beagle.B"



add chain=virus protocol=tcp dst-port=9898 action=drop comment="Drop Dabber.A-B"



add chain=virus protocol=tcp dst-port=10000 action=drop comment="Drop Dumaru.Y"



add chain=virus protocol=tcp dst-port=10080 action=drop comment="Drop MyDoom.B"



add chain=virus protocol=tcp dst-port=12345 action=drop comment="Drop NetBus"



add chain=virus protocol=tcp dst-port=17300 action=drop comment="Drop Kuang2"



add chain=virus protocol=tcp dst-port=27374 action=drop comment="Drop SubSeven"



add chain=virus protocol=tcp dst-port=65506 action=drop comment="Drop PhatBot,Agobot, Gaobot"



add chain=virus protocol=udp dst-port=12667 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=udp dst-port=27665 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=udp dst-port=31335 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=udp dst-port=27444 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=udp dst-port=34555 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=udp dst-port=35555 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=tcp dst-port=27444 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=tcp dst-port=27665 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=tcp dst-port=31335 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=tcp dst-port=31846 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=tcp dst-port=34555 action=drop comment="Trinoo" disabled=no



add chain=virus protocol=tcp dst-port=35555 action=drop comment="Trinoo" disabled=no



add action=drop chain=forward comment=";;Block W32.Kido - Conficker" disabled=no protocol=udp src-port=135-139,445



add action=drop chain=forward comment="" disabled=no dst-port=135-139,445 protocol=udp



add action=drop chain=forward comment="" disabled=no protocol=tcp src-port=135-139,445,593



add action=drop chain=forward comment="" disabled=no dst-port=135-139,445,593 protocol=tcp



add action=accept chain=input comment="Allow limited pings" disabled=no limit=50/5s,2 protocol=icmp



add action=accept chain=input comment="" disabled=no limit=50/5s,2 protocol=icmp



add action=drop chain=input comment="drop FTP Brute Forcers" disabled=no dst-port=21 protocol=tcp src-address-list=FTP_BlackList



add action=drop chain=input comment="" disabled=no dst-port=21 protocol=tcp src-address-list=FTP_BlackList



add action=accept chain=output comment="" content="530 Login incorrect" disabled=no dst-limit=1/1m,9,dst-address/1m protocol=tcp



add action=add-dst-to-address-list address-list=FTP_BlackList address-list-timeout=1d chain=output comment="" content="530 Login incorrect" disabled=no protocol=tcp

add action=drop chain=input comment="drop SSH&TELNET Brute Forcers" disabled=no dst-port=22-23 protocol=tcp src-address-list=IP_BlackList
add action=add-src-to-address-list address-list=IP_BlackList address-list-timeout=1d chain=input comment="" connection-state=new disabled=no dst-port=22-23 protocol=tcp src-address-list=SSH_BlackList_3
add action=add-src-to-address-list address-list=SSH_BlackList_3 address-list-timeout=1m chain=input comment="" connection-state=new disabled=no dst-port=22-23 protocol=tcp src-address-list=SSH_BlackList_2
add action=add-src-to-address-list address-list=SSH_BlackList_2 address-list-timeout=1m chain=input comment="" connection-state=new disabled=no dst-port=22-23 protocol=tcp src-address-list=SSH_BlackList_1
add action=add-src-to-address-list address-list=SSH_BlackList_1 address-list-timeout=1m chain=input comment="" connection-state=new disabled=no dst-port=22-23 protocol=tcp
add action=drop chain=input comment="drop port scanners" disabled=no src-address-list=port_scanners
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=fin,syn
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=syn,rst
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list=port_scanners address-list-timeout=2w chain=input comment="" disabled=no protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg

Selesai, sekarang jaringan kita sudah cukup aman menghadapi virus dan serangan hacker. Saya tidak berani menjamin 100% aman karena kita semua faham diatas langit masih ada langit ;) - semoga membantu