11/20/13

Cara Setting IP Dynamic Speedy Menjadi Domain (Solusi Setting Mikrotik Tidak Punya IP Statis Speedy)

2 comments
Kendala yang umum pada saat melakukan konfigurasi mikrotik kita tidak punya ip publik statis, ip publik yang diberikan oleh telkom speedy hanya ip publik dinamis sehingga setiap kita terhubung ke internet ip kita akan selalu berubah-ubah. Bukannya speedy tidak menawarkan layanan ip publik statis tetapi masalah biaya adalah alasan utamanya.

Tidak adanya ip statis menjadi masalah bagi kita yang menggunakan router mikrotik, karena kita harus melakukan setting ulang mikrotik berdasarkan ip yang telah berganti saat terhubung ke internet lagi. Kita bisa mensiasati masalah itu dengan menggunakan domain, selain untuk membuat ip kita menjadi statis domain juga berguna untuk mempermudah kita mengingat. Kita pun bisa melakukan kontrol jarak jauh meskipun kita tidak mengetahui ip publik speedy kita.

Sekarang kita mulai dengan mendaftar dan membuat domain terlebih dahulu.

1. Daftar di www.noip.com
2. Jika sudah mendaftar dan disetujui silahkan login ke akun yang telah anda buat
3. Klik pada tab host/redirect dan klik add host
4. Isi bagian hostname sesuai selera dan host type DNS Host (A)



Biasanya membutuhkan waktu kurang lebih lima menit untuk disetujui. Sekarang mari kita lanjutkan membuat script pada router mikrotik kita.

Login via winbox, Masuk ke tab system - script untuk lebih jelasnya silahkan perhatikan gambar dibawah ini


Kemudian masukan script dibawah ini :

# No-IP automatic Dynamic DNS update

#————— Change Values in this section to match your setup ——————

# No-IP User account info

:local noipuser “email-id-no-ip-anda“

:local noippass “password-no-ip-id-anda“

# Set the hostname or label of network to be updated.

# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.

# To specify multiple hosts, separate them with commas.

:local noiphost “nama-domain-anda“

# Change to the name of interface that gets the dynamic IP address

:local inetinterface “pppoe-user-speedy-anda“

#————————————————————————————

# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={

# Get the current IP on the interface

:local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address

:for i from=( [:len $currentIP] – 1) to=0 do={

:if ( [:pick $currentIP $i] = “/”) do={

:set currentIP [:pick $currentIP 0 $i]

}

}

:if ($currentIP != $previousIP) do={

:log info “No-IP: Current IP $currentIP is not equal to previous IP, update needed”

:set previousIP $currentIP

# The update URL. Note the “\3F” is hex for question mark (?). Required since ? is a special character in commands.

:local url “http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP”

:local noiphostarray

:set noiphostarray [:toarray $noiphost]

:foreach host in=$noiphostarray do={

:log info “No-IP: Sending update for $host”

/tool fetch url=($url . “&hostname=$host”) user=$noipuser password=$noippass mode=http dst-path=(“no-ip_ddns_update-” . $host . “.txt”)

:log info “No-IP: Host $host updated on No-IP with IP $currentIP”

}

} else={

:log info “No-IP: Previous IP $previousIP is equal to current IP, no update needed”

}

} else={

:log info “No-IP: $inetinterface is not currently running, so therefore will not update.”

}

Sekarang kita buat schedule login nya, misalnya kita setting setiap 10menit. Lakukan dengan cara mengetik perintah berikut pada terminal mikrotik :

/system scheduler add comment="Update No-IP DDNS" disabled=no interval=10m \ name=no-ip_ddns_update on-event=no-ip_ddns_update policy=read,write,test

Selesai, semoga membantu.

2 comments :

  1. bang apa skripnya ini sudah termasuk setting vpn mikrotik, setting di clientnya dialnya usernya apa?

    ReplyDelete

Silahkan tulis kritik, saran dan pertanyaan kalian.

Notice :
Tolong jangan gunakan nama Anonymous, gunakanlah Name/URL, Google ID, Wordpress ID, Tyepad dll. Mohon pengertiannya untuk menghindari spam, bagi yang masih ngeyel mengunakan anonymous terpaksa komentar kami hapus.

- Terima Kasih